[FFmpeg-devel] some question about cook decoder

Siarhei Siamashka siarhei.siamashka
Mon Jul 23 13:15:08 CEST 2007

On 7/23/07, George.Tung <dxzk7 at 163.com> wrote:
> >> Recently,I arrempted transplant the MPlayer to the ARM platform.
> >> After Compiled.I can use the player to broadcast mp3 on the ARM  platform.
> >> But cannot broadcast real audio.It seems that the cook decoder cannot work
> >> in ARM platform.
> > Generally if you have troubles running something on ARM, ensure that
> > there are no alignment problems first. You can read the following
> > wiki page for the details: http://www.nslu2-linux.org/wiki/Info/Alignment
> >
> > So you can run 'echo 3 > /proc/cpu/alignment' as root, start the program you
> > want to debug and check if it works better (but any misaligned memory access
> > will be very slow). Checking 'dmesg' log will reveal the addresses where you
> > had misaligned memory reads or writes.
> the CPU is sansumg 2410 ,arm920.

Does your reply mean that the instructions I provided above failed to
work on your CPU?

There are at least two ways to solve your problem. The preferred one
is that you identify the cause of the problem yourself with some help
and advices from this mailing list and finally submit a patch to fix
it. The second one - you can try to provide some detailed step by step
instructions and all the data needed to reproduce the problem and wait
for someone to look at it (considering the number of subscribers
having ARM hardware here, that may take ages).

If I get your your initial post right, the same setup works fine on
other architectures (ex. x86) but fails on ARM? It could be caused by
some alignment issues as it is a notable difference between x86 and
ARM. It should be quite simple to either confirm this idea or prove it
to be wrong...

More information about the ffmpeg-devel mailing list