[FFmpeg-devel] sdp.c and CONFIG_RTP_MUXER

Luca Abeni lucabe72
Tue Jul 31 10:36:10 CEST 2007

Hi all,

On Mon, 2007-07-30 at 17:53 +0200, Luca Abeni wrote:
> Tomorrow morning I'll provide a patch addressing the problem.

Ok, here are two possible ways to fix the problem: tell me if one of
them is ok and I'll commit it.

1) fix-compilation-with-sdp.diff moves the needed data and functions
from rtp.c to sdp.c.

2) fix-compilation-with-sdp-1.diff changes avf_sdp_create() to return
NULL (and not to use rtp_get_payload_type()) if the RTP muxer is not
configured. After applying this patch, the code must be reindented in a
second commit.

I tried the two patches with some sets of different configure options,
and they do not seem to cause problems.

The only other alternative I can think about is to make sdp.o
compilation conditional (but that would cause configure-dependent
linking failures in applications using avf_sdp_create()).

-------------- next part --------------
A non-text attachment was scrubbed...
Name: fix-compilation-with-sdp.diff
Type: text/x-patch
Size: 19756 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20070731/c8a3f2f4/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: fix-compilation-with-sdp-1.diff
Type: text/x-patch
Size: 473 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20070731/c8a3f2f4/attachment-0001.bin>

More information about the ffmpeg-devel mailing list