[FFmpeg-devel] [PATCH] Proposed fix for GCC 3.3 compatibility on PPC/Altivec

Guillaume POIRIER poirierg
Mon Jun 11 08:16:34 CEST 2007


On 6/11/07, Luca Barbato <lu_zero at gentoo.org> wrote:
> Guillaume POIRIER wrote:
> > Hello,
> > Attached patch is a trivial "fix" for GCC 3.3 compatibility (yes, I'm
> > trying to be nice with people who still use OSX 10.3), but I have my
> > doubts concerning the validity of this change, though regression tests
> > do pass.
> >
> does it work on the others gcc?

Current code passes regtests the the combination GCC4.0/OSX, GCC4.1/Linux.
It just doesn't compile with any version of GCC3, but I'm trying to fix this.
The patch removes several errors when compiling with GCC3, but still
doesn't allow compilation to get through. Tested with GCC4, FFmpeg
passes regression tests (I have not checked the md5).

Subversion has been the most pointless project ever started
  -- Linus Torvalds

More information about the ffmpeg-devel mailing list