[Ffmpeg-devel] Prefix for img_* functions
Thu Mar 1 23:20:51 CET 2007
On Thu, 1 Mar 2007 17:20:21 +0100
Michael Niedermayer <michaelni at gmx.at> wrote:
> On Thu, Mar 01, 2007 at 05:16:43PM +0100, Panagiotis Issaris wrote:
> > -----BEGIN PGP SIGNED MESSAGE-----
> > Hash: SHA1
> > Hi,
> > Michael Niedermayer schreef:
> > > Hi
> > >
> > > On Mon, Feb 26, 2007 at 03:27:10AM +0100, Panagiotis Issaris wrote:
> > >> Hi,
> > >>
> > >> Shouldn't the img_crop, img_copy and img_pad functions get av_ prefixes?
> > >
> > > yes but the old should stay available under #if version something and
> > > with deprecated attribute
> > How would you prefer having the old versions available? Using #define's,
> > duplicate code or the old functions calling the new ones? Or some other way?
> #defines seem best after 5sec of thoughts
Unless I'm totaly mistaken, #define would cause an ABI break.
I think the only reasonable way without breaking ABI is old functions
calling the new ones.
More information about the ffmpeg-devel