[FFmpeg-devel] [PATCH] RoQ encoder

Michael Niedermayer michaelni
Sat May 5 18:47:54 CEST 2007


Hi

On Sat, May 05, 2007 at 10:57:50AM +0200, Diego Biurrun wrote:
[...]
> > +    // Create a table of quick DPCM values
> 
> I think there is generally a slight preference for C-style /* */
> comments..

not really


> 
> > +    for(i=0;i<MAX_DPCM;i++)
> > +    {
> > +        if(diff < 0)
> > +            diff = -diff;
> > +        if(diff2 < 0)
> > +            diff2 = -diff2;
> > +    }
> 
> Please put a space between for/if and (, makes things more readable.

i think this is getting too nitpickish
i mean yes you can improve

for(i=0;i<MAX_DPCM;i++)

for example:

for(i=0; i<MAX_DPCM; i++)

is more readable IMHO but iam very afraid this could end in a coding style
flamewar and scare contrbutors away ...
iam fine with

for(i=0;i<MAX_DPCM;i++)
{
    abc
}

or

for (i=0; i<MAX_DPCM; i++){
    abc
}

or various intermedeates variations of it

what i would object against is:
for(i=0;i<MAX_DPCM;i++){ abc; def;}

but theres no such code in the patch ...

i also would object if the {  or space placement style is noticeable 
inconsistent within one file but thats neither the case here IIRC ...

[...]

-- 
Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Those who are too smart to engage in politics are punished by being
governed by those who are dumber. -- Plato 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20070505/fe8dadc4/attachment.pgp>



More information about the ffmpeg-devel mailing list