[FFmpeg-devel] LC undeclared (with faad.h)

Rene Storm rene.storm
Mon May 14 09:07:51 CEST 2007

HI Folks,

Any other ideas on that?

Maybe this is the wrong list, maybe not, but I need help on that.....

After solving this, my vacation can proceed....


I've got some trouble compiling ffmpeg with faad on SLES 10 and/or RedHat 5.

LC undeclared...


I've seen errors from other people which forgot to include faad.h, but imho my LD_FLAGS and CFLAGS are correct.

Maybe there are some missing devel packages?



Any help would be appreciated....

      ./configure --enable-libfaac --enable-liba52 --enable-libmp3lame \

        --enable-xvid --enable-libvorbis --enable-libdts --enable-x264 --enable-libfaad \

        --enable-libogg --enable-gpl --enable-pp --enable-pthreads \



make[1]: Entering directory

gcc -I"/x/sources/ffmpeg/ffmpeg"/libswscale  -DHAVE_AV_CONFIG_H
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -I"/x/sources/ffmpeg/ffmpeg" -I"/x/sources/ffmpeg/ffmpeg"
-I"/x/sources/ffmpeg/ffmpeg"/libavutil -g -I/x/ffmpeg_test/faad/include -I/x/ffmpeg_test/faac/include -I/x/ffmpeg_test/a52dec/include -I/x/ffmpeg_test/flac/include -I/x/ffmpeg_test/lame/include -I/x/ffmpeg_test/libogg/include -I/x/ffmpeg_test/libvorbis/include -I/x/ffmpeg_test/x264/include -I/x/ffmpeg_test/xvidcore/include -I/x/ffmpeg_test/ffmpeg/include -I/x/ffmpeg_test/libdts/include -I/x/ffmpeg_test/libdts/include -fomit-frame-pointer -pthread -g -Wdeclaration-after-statement -Wall -Wno-switch -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wno-pointer-sign -O3  -c -o faad.o faad.c


In file included from faad.c:30:

avcodec.h:2482: warning: 'ImgReSampleContext' is deprecated

avcodec.h:2485: warning: 'ImgReSampleContext' is deprecated

faad.c: In function 'faac_decode_frame':

faad.c:140: warning: unused variable 'sample_buffer'

faad.c: In function 'faac_decode_init':

faad.c:304: error: 'LC' undeclared (first use in this function)

faad.c:304: error: (Each undeclared identifier is reported only once

faad.c:304: error: for each function it appears in.)

make[1]: *** [faad.o] Error 1

make: *** [lib] Error 2


# head -n 304 ./libavcodec/faad.c | tail -1

faac_cfg->defObjectType = LC;

Mit freundlichen Gr??en 


Rene Storm



Janz Informationssysteme AG

Ein Unternehmen der Janz Gruppe
Friesenstr. 13a
D-20097 Hamburg

Tel. +49 (40) 851717-28
Fax +49 (40) 851717-35

E-Mail mailto:Rene.Storm at janz.de

Janz Informationssysteme AG, Im D?rener Feld 8, D-33100 Paderborn, Vorstand: Wilhelm F. Stute, Aufsichtsratsvorsitzender: Matthias Stute, Registergericht: Paderborn HRB 3734
Diese E-Mail ist vertraulich. Wenn Sie nicht der vorgesehene Empf?nger sind, verwenden Sie bitte keine Inhalte dieser E-Mail und leiten sie auch nicht weiter. Wenn Sie f?lschlicherweise diese E-Mail bekommen haben, informieren Sie uns bitte umgehend und l?schen dieses Dokument. This e-mail is confidential. If you are not the intended recipient, please do not disclose or use the contents of the e-mail. If you have erroneously received this e-mail, please inform us immediately by return e-mail and delete the document.

Reliable Solutions seit 1982: Die Janz Unternehmensgruppe feiert 25. Geburtstag!

-----Urspr?ngliche Nachricht-----
Von: ffmpeg-devel-bounces at mplayerhq.hu [mailto:ffmpeg-devel-bounces at mplayerhq.hu] Im Auftrag von Mike Melanson
Gesendet: Freitag, 11. Mai 2007 18:00
An: FFmpeg development discussions and patches
Betreff: Re: [FFmpeg-devel] LC undeclared (with faad.h)

Rene Storm wrote:
> Hi Mike,
>> ...install FAAC.
> faac is installed and included
> any other suggestions?

Yeah, take it up on ffmpeg-user as Diego recommended.

	-Mike Melanson
ffmpeg-devel mailing list
ffmpeg-devel at mplayerhq.hu

More information about the ffmpeg-devel mailing list