[FFmpeg-devel] New format: Monkey's Audio Codec (ape)

Luca Barbato lu_zero
Fri May 18 18:42:33 CEST 2007

Louise Hoffman wrote:
> Okay, so what you are saying is, that there is not a very strong pull
> to implement it because it is not version compatible?

Basically because wavpack and flac do a better job w/out being obnoxious.

> I recall once trying to decode an ape file where the decode was too
> old, and it failed. As long as it fails and doesn't decode it wrong,
> would it be possible to detect for compatibility?

everything is possible as long it isn't maliciously crafted ^^

> Or is it a matter of always have the latest decoder (into ffmpeg)?

Another problem in implementing the beast is having to support those
different encodings (using quirks like for mpeg4
broken/incomplete/"creative" implementations?)...



Luca Barbato

Gentoo/linux Gentoo/PPC

More information about the ffmpeg-devel mailing list