[FFmpeg-devel] [PATCH] faad2 version 2.5 support

Ivan Kalvachev ikalvachev
Sun Oct 7 03:25:48 CEST 2007

2007/10/6, Dominik 'Rathann' Mierzejewski <dominik at rangers.eu.org>:
> On Saturday, 06 October 2007 at 02:01, Ivan Kalvachev wrote:
> > 2007/10/6, Frank Liu <gfrankliu at gmail.com>:
> > [...]
> > >
> > > If I apply my patch and rebuild ffmpeg, same command runs without any errors.
> > >
> > > Thoughts?
> Your FAAD2 has been patched not to include backward compatibility APIs.
> > I think your patch would break building of the older FAAD (FAAC?) versions.
> Indeed.
> > Some people still prefer the old version because license changes by
> > Nero rendered the library GPL incompatible.
> AFAIK they're not as GPL incompatible as we thought, as long as we don't use
> FAAD code in something else than AAC decoder. See this bugzilla report for
> more information: http://bugzilla.livna.org/show_bug.cgi?id=1482

Actually the letter from FSF ends with:
  "... Because of this, I would have to say that this text
  is an additional requirement, and as such is not compatible with the GPL."...
And goes on to talk about tainting.

I have no idea where you and your friends got the idea that it IS
compatible and why you have voted about making package out of it.
Maybe because you all read only the start of the letter.
I really hope you are not distributing it.

More information about the ffmpeg-devel mailing list