[FFmpeg-devel] [PATCH] faad2 version 2.5 support

Frank Liu gfrankliu
Sun Oct 7 19:19:04 CEST 2007

On 10/7/07, Rich Felker <dalias at aerifal.cx> wrote:
> On Sat, Oct 06, 2007 at 03:01:42AM +0300, Ivan Kalvachev wrote:
> > 2007/10/6, Frank Liu <gfrankliu at gmail.com>:
> > [...]
> > >
> > > If I apply my patch and rebuild ffmpeg, same command runs without any errors.
> > >
> > > Thoughts?
> >
> > I think your patch would break building of the older FAAD (FAAC?) versions.
> > Some people still prefer the old version because license changes by
> > Nero rendered the library GPL incompatible.
> IMO we should explicitly reject new versions rather than being
> compatible with both.

If you want to "reject", the easiest solution is to patch the
configure to default enable libfaadbin when libfaad is enabled. As I
reported earlier, ffmpeg will error out if you are using the new faad2
when faadbin is enabled. If you are using the old faad2, this change
won't affect you.
This brings up another question: what does faadbin give us? I see only
liba52 and libfaad have the runtime loading option. Is there a reason
why those two libs are different from all other libs?

More information about the ffmpeg-devel mailing list