[FFmpeg-devel] ffmpeg or ffserver to stream?

Claudio Bertozzi becl75
Mon Sep 3 17:19:53 CEST 2007

I fixed some bug in my code (obviously full of them..) and now,
setting the correct PTS in every packet, the stream seems to be
correct even without the AVFMT_FLAG_GENPTS flag in my AVFormatContext
(I grab the frame from a webcam and resend them after an MPEG1
The strange thing now is that the stream received with VLC it's
correct (I check it frame by frame with Ethereal checking also the
timestamps and the frame type and both are well flagged) but VLC
decode only I.frames skipping all the P-frames (if I set the GOP to 1,
VLC doesn't skip any frame...but in this case I feel that the MPEG
encoding work is a little useless :) ). Is possible that frame types
are flagged also in another place (like inside RTP header)?
Another feature is that the same stream (GOP=12 or GOP=1), written to
a .mpeg file and played with VLC, is played without frame skipping
Any suggestion?



2007/9/3, Luca Abeni <lucabe72 at email.it>:
> Claudio Bertozzi wrote:
> [...]
> > some errors in RTP streaming, if I watch .mpg video with VLC I don't
> > see any error, but if I stream it in RTP using:
> > "ffmpeg -re -i ../../temp.mpg -vcodec copy -an -f rtp
> > rtp:// -vn" command line, VLC gives me a lot of pts sync
> > error like:
> > "main warning: vout synchro warning: pts != current_date (29211)
> > main warning: dts != current_pts (24367)"
> > and frames has many visible errors.
> Until we figure out a better solution, you will need to add "-fflags
> +genpts" before "-i" (I mentioned that the AVFMT_FLAG_GENPTS flag is needed)
>                         Luca
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at mplayerhq.hu
> http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-devel

More information about the ffmpeg-devel mailing list