[FFmpeg-devel] [PATCH] Implement PAFF in H.264

Neil Brown neilb
Wed Sep 19 04:12:47 CEST 2007

On Tuesday September 18, heydowns at borg.com wrote:
> Attached is a patch that implements PAFF in H.264.
> I don't expect this to be accepted right away, due to size and
> complexity, but I want to get it out there for review and for people
> to try out and comment on.

I just tried it on my clips from my Sony HDR-SR1 Camcorder.

1/ While somewhat faster than the reference decoder, it is still
   slower than real-time on my 2GHz Intel Core2 processor.  So it is
   still worth looking for performance improvements.

2/ There are some strange artifacts at the edges when I pan left or
   right.  This png shows an example.  It is clipped from the left edge
   of a frame showing a parking lot.  Notice there are some pale
   patches down the left side.  It looks like the reference mb was
   thought not to be available, so grey was used instead.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: edgeerrors.png
Type: image/png
Size: 41388 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20070919/8e4a69d1/attachment.png>
-------------- next part --------------

3/ Something goes wrong with the re-ordering of frames.  The first few
   seconds seem OK.  But then I get an effect which seems like
   adjacent frames are swapped. e.g. a car door should be closing, but
   it looks like it closes a bit, then opens, then closes some more,
   then opens a bit etc.  Taking a sample 10 frames, the correct
   ordering is
         2 1 4 5 3 6 8 7 10 9
   which is close to swapping each pair, but not quite.

The (12Meg) clip at
shows both of these when I run 'ffplay' on it.
The frame-reordering doesn't manifest until the last couple of seconds.


More information about the ffmpeg-devel mailing list