[FFmpeg-devel] [RFC] Sechole in gcc 3.3+ and 4.*

Alexander Strange astrange
Mon Apr 7 21:50:59 CEST 2008

On Apr 7, 2008, at 10:19 AM, Wolfram Gloger wrote:
> Hi,
>> Lars T=E4uber, told me about a sechole in gcc 4.2+
>> http://www.heise.de/newsticker/GCC-optimiert-Sicherheitspruefungen-weg--/me=
>> ldung/106097
> Oh no, the worst Heise news article in months, if not years.  Please
> check the comments also, not just the grossly misleading article.
>> http://www.kb.cert.org/vuls/id/162289
>> The issue described though is rather harmless.
> Indeed -- in particular there is certainly no such "sechole" in gcc.

gcc will optimize that away, but apparently so will several other  
compilers (LLVM, IBM XLC, PathScale (whatever that is)).
If you're wondering if that affects anything, compile with 4.3 and - 
Wstrict-overflow, maybe with =5 if you really like warnings.


More information about the ffmpeg-devel mailing list