[FFmpeg-devel] [MPlayer x ffplay] Helping understanding different video output

André Goddard Rosa andre_rosa
Thu Apr 10 23:38:56 CEST 2008

Hi, all!

	I'm trying to understand why the ffplay onscreen output is very
different from MPlayer output.

	I put two small screenshots of the same quicktime movie displaying
different on screen output:

	Do you know the reason off hand only by looking at the pictures?

Thanks a lot,
Andr? Goddard Rosa

-- Detailed run information

ffplay console output:
	FFplay version SVN-r12685, Copyright (c) 2003-2008 Fabrice Bellard,
et al.
	  configuration: --enable-libfaac --enable-libfaad
--enable-libmp3lame --enable-gpl
	  libavutil version: 49.6.0
	  libavcodec version: 51.54.0
	  libavformat version: 52.13.0
	  libavdevice version: 52.0.0
	  built on Apr 10 2008 14:27:20, gcc: 4.0.2 20050901 (prerelease)
(SUSE Linux)

Mplayer console output:
MPlayer 1.0rc2-4.0.2 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 CPU         T5600  @ 1.83GHz (Family: 6, Model: 15,
Stepping: 6)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1 Compiled for x86
CPU with extensions: MMX MMX2 SSE SSE2
mplayer: could not connect to socket
mplayer: Connection refused
Failed to open LIRC support. You will not be able to use your remote

Playing /mnt/hgfs/goddard/_/apagar/englishGloboRecordingTM2.MOV.
Quicktime/MOV file format detected.
[mov] Video stream found, -vid 0
[mov] Audio stream found, -aid 1
VIDEO:  [jpeg]  848x480  24bpp  30.000 fps    0.0 kbps ( 0.0 kbyte/s)
[VO_XV] It seems there is no Xvideo support for your video card available.
[VO_XV] Run 'xvinfo' to verify its Xv support and read [VO_XV]
[VO_XV] See 'mplayer -vo help' for other (non-xv) video out drivers.
[VO_XV] Try -vo x11.
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family Selected
video codec: [ffmjpeg] vfm: ffmpeg (FFmpeg MJPEG decoder)
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 8000 Hz, 1 ch, u8, 64.0 kbit/100.00% (ratio: 8000->8000) Selected
audio codec: [pcm] afm: pcm (Uncompressed PCM)
AO: [oss] 8000Hz 1ch u8 (1 bytes per sample) Starting playback...
VDec: vo config request - 848 x 480 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 3) Movie-Aspect is undefined - no
prescaling applied.
VO: [x11] 848x480 => 848x480 Planar YV12 [swscaler @ 0x8926750]SwScaler:
using unscaled yuv420p -> rgb32 special converter

More information about the ffmpeg-devel mailing list