[FFmpeg-devel] Compilation breakage of libpostproc on Darwin 9 (PowerPC-only)

Guillaume POIRIER poirierg
Tue Apr 29 20:53:03 CEST 2008


On Tue, Apr 29, 2008 at 12:26 PM, Felix Paul K?hne
<fkuehne.videolan at googlemail.com> wrote:
>  Hello there,
>  we had to disable the AltiVec support of the current FFmpeg trunk in
>  order to be able to keep VLC media player compiling on PowerPC-based
>  Macs. As requested by M?ns, you can find a compilation log on <http://paste.videolan.org/3943
>   >
>  We are using the following options to compile FFmpeg:
>  CC="gcc -isysroot /Developer/SDKs/MacOSX10.4u.sdk"
>  CXX="g++ -isysroot /Developer/SDKs/MacOSX10.4u.sdk"
>  LD="ld -arch ppc -syslibroot /Developer/SDKs/MacOSX10.4u.sdk"
>  ./configure --enable-libmp3lame --enable-libfaac --enable-liba52 --
>  enable-swscale --extra-cflags="-arch ppc -mtune=G4  -
>  DMACOSX_DEPLOYMENT_TARGET=10.4 -mmacosx-version-min=10.4  -
>  DRUNTIME_CPUDETECT" --enable-gpl --enable-postproc --disable-vhook --
>  disable-ffserver --disable-ffmpeg --disable-ffplay --disable-devices --
>  disable-protocols
>  It would be great to work with you to find a solution to this problem.
>  I'm reachable on Freenode under "feepk" in the usual CEST hours.

I can't reproduce the problem here with a PPC/Tiger machine.


I don't measure a man's success by how high he climbs but how high he
bounces when he hits bottom.
 -- George S. Patton

More information about the ffmpeg-devel mailing list