[FFmpeg-devel] [PATCH] high precision mp3 decoding needs CONFIG_AUDIO_NONSHORT which is never set

Mathieu Velten matmaul
Sun Dec 7 14:51:57 CET 2008

patch attached

Mathieu Velten
-------------- next part --------------
A non-text attachment was scrubbed...
Name: hp_mp3.diff
Type: application/octet-stream
Size: 423 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20081207/958556be/attachment.obj>

>From =?UTF-8?B?zqDOsc69zrHOs865z47PhM63z4IgzprOsc+Ez4POsc67zr/Pjc67?=  Sun Dec  7 14:56:57 2008
From: =?UTF-8?B?zqDOsc69zrHOs865z47PhM63z4IgzprOsc+Ez4POsc67zr/Pjc67?= (=?UTF-8?B?zqDOsc69zrHOs865z47PhM63z4IgzprOsc+Ez4POsc67zr/Pjc67?=)
Date: Sun, 7 Dec 2008 15:56:57 +0200
Subject: [FFmpeg-devel] In Leopard library is broken if compiled with
	Tiger compatibility
In-Reply-To: <yw1xfxl0xgc8.fsf at thrashbarg.mansr.com>
References: <AB08EDC6-8DEE-456A-8E3B-2A3B78D03254 at panayotis.com>
	<yw1xk5acxhs3.fsf at thrashbarg.mansr.com>
	<D2800AF4-5846-40C2-8DA0-02B1610FEA23 at panayotis.com>
	<yw1xfxl0xgc8.fsf at thrashbarg.mansr.com>
Message-ID: <18EA5EFE-71F7-46DF-8AC6-4B77735439B6 at panayotis.com>

On 07 ??? 2008, at 3:30 ??, M?ns Rullg?rd wrote:

> ?????????? ??????????? <panayotis at panayotis.com>  
> writes:
>> On 07 ??? 2008, at 2:59 ??, M?ns Rullg?rd wrote:
>>> ?????????? ???????????  
>>> <panayotis at panayotis.com>
>>> writes:
>>>> In Mac OS X 10.5, in order to produce binary compatible code with
>>>> version 10.4, there is a need to manually add the command line
>>>> argument
>>>> -mmacosx-version-min=10.4
>>>> or else the produced code will not be binary compatible with  
>>>> previous
>>>> version.
>> ...
>>> The Apple build system is broken.  There's nothing we can do about
>>> that.
>> As most systems. Windows for example ;)
>> Yes there is, I even included a proposed solution. If you don't want
>> to do anything, even with a solution provided, it's another thing.
> What you suggested is not a solution.  It's an ugly hack that appears
> to work for you.
> Can FFmpeg be built on an OSX 10.4 system?

Ugly hack is the    #define _XOPEN_SOURCE 600
And this is what I was trying to avoid.
This should be really defined only for the systems that really need it  
(I think it's for windows only but I might be wrong).
The correct should be something like
#ifdef __WINDOWS__
etc. but I don't really know which operating systems really need the   
mkstemp() function hack with this #define.

About your question:  Yes it works, but it actually breaks  
compatibility issues with other OS X versions.
If you need more information I will be more than happy to explain the  

More information about the ffmpeg-devel mailing list