[FFmpeg-devel] In Leopard library is broken if compiled with Tiger compatibility

David DeHaven dave
Sun Dec 7 20:57:38 CET 2008

>> Can FFmpeg be built on an OSX 10.4 system?
> Yes, FFmpeg can be built on 10.4 with no problems.

And on Leopard targeting 10.4 with -mmacosx-version-min=10.4 or  
setting MACOSX_DEPLOYMENT_TARGET to 10.4 in my case. Though I only  
build a minimal LGPL version of lavxxx shared libs otherwise it's  
static, but it works and runs on 10.4 and 10.5.

The only system related issues I really have are with mplayer linking  
against libraries installed by MacPorts, and those are eliminated by  
removing /opt/local/bin from the PATH before configuring.

Oh, I also specify the 10.4 SDK using "-isysroot /Developer/SDKs/ 


More information about the ffmpeg-devel mailing list