[FFmpeg-devel] [PATCH] ALSA for libavdevice

Måns Rullgård mans
Thu Dec 18 15:41:27 CET 2008

Luca Abeni wrote:
> Luca Abeni wrote:
> [...]
>>> ok, if someone has tested both recording & playback (ideally with video)
>>> and
>>> it worked (including AV sync)
>> I tried to test the latest version, but it turns out that the alsa library
>> installed on my machine does not provide SND_PCM_TSTAMP_ENABLE and
>> snd_pcm_htimestamp(). I am on Ubuntu 8.04.1.
>> Which version of the alsa library is needed?
>> I am rebooting to a debian testing/unstable machine to see if it provides
>> a good alsa library...
> Ok; with debian unstable I've been able to compile the alsa input format,
> but... It does not seem to work :(

That's an accurate summary of alsa in general, not only in debian.  I
recently found that upgrading to alsa-lib to 1.0.18 broke all my apps.

M?ns Rullg?rd
mans at mansr.com

More information about the ffmpeg-devel mailing list