[FFmpeg-devel] Help with wmv3 video embedded in a .mov file

Chris Marrin chris
Fri Dec 19 07:15:44 CET 2008

Yesterday, I posted a message to FFmpeg-user:

     [FFmpeg-user] Problem with wmv3 video embedded in quicktime	 

I've been debugging this issue and have found that (perhaps among  
other things) the problem has to do with the fact that the .mov file  
does not grab the header data that asf_read_header() does at asf.c: 
327. I don't know if the data is not in the .mov file, or if mov.c is  
just not bothering to get it.

Whether it is in the file or not, the quicktime player can play the  
movie just fine, so it seems like this data is either there or can be  
synthesized. I don't know enough about ASF or WMV3 to go any further.  
Is anyone familiar with this issue? Anyone ever tried tracking it down?

I can provide a short offending clip if need be. But my message to  
FFmpeg-user describes a simple way to create one. I'm new to the list,  
so let me know where I would dump such a file if it's needed.

I'm making a Cocoa-based video encoding tool, similar to the now  
defunct Visual Hub (http://www.techspansion.com/), called VideoMonkey (http://videomonkey.org 
). If I want to process this file, I need to use movtoy4m (which uses  
the quicktime framework) to convert the file from qt to a yuv stream,  
and then use ffmpeg to process the result. But this is a hassle (I  
have to pull out the audio and then mux it back in) and it doesn't  
produce very good results, so I'd like to try to get ffmpeg to handle  
it directly.

Any help would be great, thanks.

chris at marrin.com

More information about the ffmpeg-devel mailing list