[FFmpeg-devel] [PATCH] powerpc --> ppc

Luca Barbato lu_zero
Sat Dec 27 11:55:33 CET 2008

Diego Biurrun wrote:
> On Thu, Dec 25, 2008 at 05:02:55PM +0100, Guillaume POIRIER wrote:
>> On Thu, Dec 25, 2008 at 3:10 PM, Diego Biurrun <diego at biurrun.de> wrote:
>>> There is some inconsistency in the way we handle the naming of the
>>> PowerPC/PPC architecture right now.  Sometimes it is powerpc, sometimes
>>> ppc.  I suggest we go for ppc, which we also use as subdirectory name.
>>> $attached implements this and will help me with some build system
>>> changes in the future.
>> I support this change.
> Luca, what do you say?

POWERPC or PPC are the same for me, so apply the patch =)

>>> Another thing I noticed: What is ARCH_POWERPC_405?  It is never set...
>> This was added by this _very old_ commit:
>> commit 45c7805311002362b42e98a664419bfe8ff23931
>> Author: bellard <bellard at 9553f0bf-9b14-0410-a0b8-cfaf0461ba5b>
>> Date:   Wed Jun 5 14:25:06 2002 +0000
>>     removed unused code - began to merge alpha specific stuff - added
>> mac macros for suitable CPUs
>>     git-svn-id: file:///var/local/repositories/ffmpeg/trunk at 667
>> 9553f0bf-9b14-0410-a0b8-cfaf0461ba5b
> That's just the one in simple_idct.c, the one in ppc/mathops.h is from
> September 2006.
>> I don't think there's many people who actively use PowerPC 405 besides
>> people who hack their DreamBox (http://en.wikipedia.org/wiki/Dreambox)
>> and students (since the core is freely available), so I don't care if
>> ever you want to remove the core relative to it.
> Luca, what do you say?

That the simple_idct.c should be cleaned and the code should remain 
since there are many ppc4xx, some pretty much recent, and are used on 
stb IIRC.

We could rename the symbol to PPC4XX and update the configure 
accordingly IF there are people interested (if anybody is using them 
please tell)



Luca Barbato
Gentoo Council Member
Gentoo/linux Gentoo/PPC

More information about the ffmpeg-devel mailing list