[FFmpeg-devel] [PATCH] add alloc_put_byte function

Paul Kelly paul
Sun Feb 3 12:41:50 CET 2008

On Mon, 14 Jan 2008, Baptiste Coudurier wrote:

> Baptiste Coudurier wrote:
>> Reimar D?ffinger a ?crit :
>>> On Fri, Dec 21, 2007 at 09:49:05AM +0100, Reimar D?ffinger wrote:
>>>> On Thu, Dec 20, 2007 at 11:58:32PM +0100, Baptiste Coudurier wrote:
>>>> [...]
>>>>> For consistency, can we choose a naming convention ?
>>>>> We got:
>>>>> avcodec_alloc_context
>>>>> av_alloc_format_context
>>>>> Furthermore, ByteIOContext can be used to read data, so naming it
>>>>> alloc_put_byte seems somehow odd to me.
>>>> I just went on analogy to init_put_byte, I don't like it particularly
>>>> either. I'll go with anything you agree on ;-)
>>> Applied with only av_ prefix added, I do not want to wait forever with a
>>> depending patch.
>>> Feel free to come up with a better name and then bump the lavf version
>>> (I originally just forgot to do it, but now think it might be good as it
>>> give as chance to change the name without breaking API in the strict
>>> sense ;-) ).
>> Ok, I already suggested av_alloc_byteio_context, anyone against it ?
> I'll apply the following patch in a few hours.

Any chance of this being applied? It's just I "accidentally" used the new 
function in some code I wrote for someone and so have had to send them a 
new version ready to be used when the function has been renamed - we're 
still waiting!



More information about the ffmpeg-devel mailing list