[FFmpeg-devel] [PATCH]Fix number of first file in image2 format

Michael Niedermayer michaelni
Sun Feb 10 01:41:34 CET 2008

On Fri, Feb 01, 2008 at 02:54:22PM +0100, Michel Bardiaux wrote:
> Michel Bardiaux wrote:
>> Michel Bardiaux wrote:
>>> Currently, input probes first at zero, but output begins at number 1.
>>> Note this is just a fix for the default, I am preparing a patch that will 
>>> add an AVOption for the start of the sequence (which will save those 
>>> having scripts relying on the present behaviour!)
> Here is the full monte :-)
>> Revised patch. Scrutiny please, esp. the maintainer ie Michael; I am not
>> sure I understand the purpose of the conditions after
>> av_get_frame_filename, and am not
>> sure they were correct before or are now.
> Same request for this version, please.

Iam not sure what the initial 0/1 is supposed to fix? If theres no 0
file, it will start at 1 anyway i think ...

A user specified initial number on reading as you implemented it is not
correct. img2.c should be fixed to support seeking, if it does support
seeking then the initial number is just a seek ...

And some of the changes i think might break -f image2 -i file.whatever
that is without %d.

Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Many things microsoft did are stupid, but not doing something just because
microsoft did it is even more stupid. If everything ms did were stupid they
would be bankrupt already.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20080210/3e6c3f9c/attachment.pgp>

More information about the ffmpeg-devel mailing list