[FFmpeg-devel] Fix NTP time in RTCP SR packets

Luca Abeni lucabe72
Fri Feb 15 09:34:19 CET 2008

Hi Reimar,

Reimar D?ffinger wrote:
> Hello,
> On Fri, Feb 15, 2008 at 08:40:40AM +0100, Luca Abeni wrote:
>> I recently notice some errors in the statistics
>> computed on RTP streams generated by libavformat.
>> After some investigation, I noticed that the errors
>> are due to the fact that rtcp_send_sr() is invoked
>> with the gettimeofday() time and not the NTP time as
>> a parameter.
> As you probably know I am always and still opposed to leaking
> unnecessary information about the local system to a server,
> and thus strongly dislike the fact that gettime is used at all, at
> least without enabling it explicitly.

I suspect the problem you are pointing out is orthogonal
respect to my fix, since av_gettime() is already used...

Anyway, as far as I understand there is no choice, because the
standard mandates the use of NTP time. And I do not think that
this code is sending out any information about the local
computer (apart of the fact that the clock is currently set):
this code is used during live streaming, so the receiver can
already know that I am sending the packets now, even without
reading the NTP time in them :)

Or am I misunderstanding your comment?

In any case, if we can find a standard-compliant way of setting
the RTCP fields without leaking information about the local
system, I am in favour of it (suggestions welcome).


More information about the ffmpeg-devel mailing list