[FFmpeg-devel] [PATCH] [4/??] [1/1] Libavfilter - Build changes

Vitor Sessak vitor1001
Sun Feb 24 11:58:08 CET 2008


M?ns Rullg?rd wrote:
> "V?ctor Paesa" <wzrlpy at arsystel.com> writes:
>> Hi,
>> Vitor Sessak said:
>>> Vitor Sessak wrote:
>>>> Hi
>>>> M?ns Rullg?rd wrote:
>>>>> Vitor Sessak writes:
>>>>>> M?ns Rullg?rd wrote:
>>>>>>> Vitor Sessak writes:
>>>>>>>> This patch is unrelated to the graph patch (in the sense that it
>>>>>>>> can be applied before or after it). It allows to compile
>>>>>>>> libavfilter with "configure --enable-avfilter", but it will not be
>>>>>>>> used at this point for anything.
>>>>>>>> (no need to hurry in reviewing this, I'll be without internet
>>>>>>>> until next week)
>>>>>>>> Index: configure
>>>>>>>> ==================================================================>>>>>
>>>>>>>> --- configure    (revision 11882) +++ configure    (working copy)
>>>>>>>> @@ -72,6 +72,8 @@
>>>>>>>>    echo "                           and ffmpeg will be
>>>>>>>> unredistributable [default=no]"
>>>>>>>>    echo "  --enable-pp              enable GPLed postprocessing
>>>>>>>> support [default=no]"
>>>>>>>>    echo "  --enable-swscaler        software scaler support
>>>>>>>> [default=no]"
>>>>>>>> +  echo "  --enable-avfilter        video filter support (replaces
>>>>>>>>  vhook) [default=no]"
>>>>>>>> +  echo "  --enable-avfilter-lavf   video filters dependant on
>>>>>>>> avformat [default=no]"
>>>>>>> Why this distinction?
>>>>>> Because there is no point of having such a big dependence for just a
>>>>>>  few filters (like the vsrc_movie). Think about someone who wants
>>>>>> just  to filter video, but don't cares about encoding/decoding.
>>>>> So why not simply make the relevant filters depend on libavformat
>>>>> directly?
>>>> You mean compile it, unless configure is called with
>>>> --disable-avformat?  Sounds reasonable to me. V?ctor, Diego?
>>> Sorry to reply to self, but I was not clear. I meant to ask your opinion
>>>  (but if you want to fix it you are welcome too!).
>> Fine for me, but I don't see --disable-avformat in configure --help, does
>> the fix is to allow conditional build of libavformat?
> Hmm, somehow I'd got the idea there was such an option, but that seems
> not to be the case.  We could of course add one, though.

Well, if no one object to it, I will commit my original patch in 24 
hours, unless someone want to implement the --disable-avformat opt...


More information about the ffmpeg-devel mailing list