[FFmpeg-devel] [PATCH] Prepare pp_help for ABI change on version bump

Michael Niedermayer michaelni
Tue Jan 8 18:33:04 CET 2008

On Tue, Jan 08, 2008 at 03:22:28PM +0100, Diego 'Flameeyes' Petten? wrote:
> The attached patch adds a conditional on pp_help declaration and
> definition, this way when libpostproc's version is bumped, pp_help is
> moved from .data.relro to .rodata automatically.

> Make pp_help a constant array of characters to move it to .rodata.
>  const char *const pp_help=
> +#else
> +const char pp_help[] =
> +#endif

LIBPOSTPROC_VERSION_INT is not < (51<<16) currently


Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

It is not what we do, but why we do it that matters.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20080108/6f2abba5/attachment.pgp>

More information about the ffmpeg-devel mailing list