[FFmpeg-devel] Compiling with x264 as a user

Niklas Saers niklassaers
Sat Jan 12 13:22:41 CET 2008

I'm trying to compile ffmpeg with libx264 on a Debian Linux system as a user.

What I've done is:

mkdir ~/local
cd ~/local
svn co svn://svn.videolan.org/x264/trunk x264
cd x264
./configure --prefix=~/local
make && make install
cd ..
svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg
cd ffmpeg
./configure --prefix=~/local --enable-gpl --enable-libx264
--extra-cflags="-I~/local/include -L~/local/lib"
make && make install

The error I get is:
ERROR: x264 not found
If you think configure made a mistake, make sure you are using the latest
version from SVN.  If the latest version fails, report the problem to the
ffmpeg-devel at mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.err" produced by configure as this will help
solving the problem.

config.err is attached, but the problem should be around:
check_lib x264.h x264_encoder_open -lx264
check_header x264.h
BEGIN /tmp/ffmpeg-conf-77-1431-12276.c
    1   #include <x264.h>
    2   int x;
END /tmp/ffmpeg-conf-77-1431-12276.c
gcc -I~/local/include -L~/local/lib -fomit-frame-pointer -E -o /tmp/ffmpeg-conf-
8401-1431-22353.o /tmp/ffmpeg-conf-77-1431-12276.c
/tmp/ffmpeg-conf-77-1431-12276.c:1:18: x264.h: No such file or directory
ERROR: x264 not found

x264.h  is indeed present in ~/local/include/x264.h and libx264.a in ~/local/lib

What am I missing? The CFLAGS variable from config.err looks all right to me:
CFLAGS=' -I~/local/include -L~/local/lib'

I'm very much looking forward to your help. :-)


   Niklas Saers
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.err
Type: application/octet-stream
Size: 36603 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20080112/f0f092cb/attachment.obj>

More information about the ffmpeg-devel mailing list