[FFmpeg-devel] regression - mpeg2 interlace/topfield flags not set anymore

Michael Niedermayer michaelni
Sun Jan 27 01:57:34 CET 2008

On Sun, Jan 27, 2008 at 01:26:40AM +0100, christophelorenz wrote:
> Ok, I found the source of the problem...
> When parsing flags, the flags values are represented internally as a 
> number, passed as in a string.
> The problem is that the flags are represented as hex values 0x20140000 
> while the other values are base 10.
> So when ff_eval2 wants to parse the flag number, it has to parse hex.
> Didn't go further into ff_eval2 but I can say that under linux it can 
> parse hex but not under win32 : ff_eval2("0x20140000"....)=0
> So the fix is either make ff_eval2 work with hex under win32, or return 
> the flags as base10 numbers.
> The base10 fix consist simply in a one line change in opt.c
> I can't tell if it can have other implication in the code however.

flags should be printed in hex or as a series of named constants
base10 is unreadable

Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

No human being will ever know the Truth, for even if they happen to say it
by chance, they would not even known they had done so. -- Xenophanes
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20080127/37bf5e0d/attachment.pgp>

More information about the ffmpeg-devel mailing list