[FFmpeg-devel] Reduce the size of AVRtpPayloadTypes
Fri Mar 28 08:23:52 CET 2008
Michael Niedermayer wrote:
> On Thu, Mar 27, 2008 at 01:44:15PM +0100, Luca Abeni wrote:
>>> changing it to enc_name would be
>>> more effective, especially on 64 bit systems (probably no relevant
>>> difference on 32 bit systems though, except maybe better cache
>>> utilization which I doubt is relevant here).
>> Is this the preferred ffmpeg's style?
>> If yes, I'll change it in "enc_name" (I think in this case the two
>> solutions are equivalent, and this is just a matter of taste).
> The pointers make the table unshareable with PIC (ironic ...)
> They also all require a relocation, even with PIC (also ironic ...)
I was not aware of these problems, thanks for pointing them out. At
this point, I'll happily commit Reimar's suggested version.
More information about the ffmpeg-devel