[FFmpeg-devel] [PATCH] ff_shift (left shift with allowed negative offset) implementation
Sat May 10 19:23:50 CEST 2008
2008/5/10 Vladimir Voroshilov <voroshil at gmail.com>:
> 2008/5/10 Michael Niedermayer <michaelni at gmx.at>:
>> On Sat, May 10, 2008 at 08:42:09PM +0700, Vladimir Voroshilov wrote:
>>> 2008/5/10, Michael Niedermayer <michaelni at gmx.at>:
>>> > and the name is not good, it should give some hint that offset is meant
>>> > leftward and that value is signed.
>>> the given name is the best a can invent for it.
>>> Please anybody suggest better.
>> ff_bidir_sal makes sense to me but iam not sure if it makes sense to anyone
>> else (ones not knowing x86 asm), sal being shift arithmetic (signed) left.
>> maybe someone else has a better suggestion
> ff_shl_bidir ?
This is patch with above name.
Vladimir Voroshilov mailto:voroshil at gmail.com
JID: voroshil at gmail.com, voroshil at jabber.ru
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 684 bytes
Desc: not available
More information about the ffmpeg-devel