[FFmpeg-devel] [PATCH] Use pkg-config for libschroedinger libs

Uoti Urpala uoti.urpala
Mon May 12 21:08:21 CEST 2008

On Mon, 2008-05-12 at 18:32 +0100, M?ns Rullg?rd wrote:
> Uoti Urpala <uoti.urpala at pp1.inet.fi> writes:
> > IMO M?ns is wrong. libschroedinger is not a part of POSIX and using its
> > API requires the presence of additional files beyond POSIX in any case.
> > If that includes not only .h files but also .pc files and pkg-config
> > there's nothing wrong with that.
> Yes, there is.  Virtually all packages that use pkg-config could be
> fix to not need it.

With enough kludges they could be changed but that doesn't mean it would
be a "fix" or beneficial.

>   Encouraging its use is foolish at best, and
> quite possibly harmful.  It comes from the same kind of thinking that
> spawned autoconf/automake.

I don't think any "kind of thinking" is responsible for most of the
problems autoconf/automake have (except maybe the ideal of going for
maximum portability which necessarily implies low-level tools and lots
of ugliness). Also pkg-config is so different from autoconf/automake
that it's hard to see how it could have the same kind of problems.

Even if you for some reason don't like pkg-config yourself opposing the
use of libraries according to their API when that API requires
pkg-config is a rather extreme position IMO.

More information about the ffmpeg-devel mailing list