[FFmpeg-devel] [PATCH] RDT/Realmedia patches #2

Ronald S. Bultje rsbultje
Wed Nov 19 23:00:52 CET 2008

Hi Michael,

On Wed, Nov 19, 2008 at 4:21 PM, Michael Niedermayer <michaelni at gmx.at> wrote:
> On Tue, Nov 18, 2008 at 08:29:09PM -0500, Ronald S. Bultje wrote:
>> @@ -36,7 +36,12 @@
>>  #include <libavcodec/bitstream.h>
>>  struct RDTDemuxContext {
>> -    AVFormatContext *ic;
>> +    AVFormatContext *ic; /**< the containing (RTSP) demux context */
>> +    /** stream context of the first stream of the set of streams that
>> +     *  this particular RTPSStream and its contained RDTDemuxContext
>> +     *  are describing. In case of multiple streams per set, the rest
>> +     *  of the streams are directly following in the streams array
>> +     *  of the 'ic' variable (e.g. me->ic->streams[me->st->index + 1]) */
>>      AVStream *st;
> I think this design is a mess ...
> At least st should be renamed to something like first_st_of_set

I can change stuff, just be a little bit specific about what exactly
is a mess. Current design is sort of an evolution of me trying to get
things to work, it's not always thought through very well, I totally
admit that.

As a slightly different solution, I can keep the AVStream* as it is,
so that at least these two first struct members are / can be shared
between RDT/RTPDemuxContext (allowing for a parent struct that I can
cast to regardless of transport). I would then rename it to first_st
(st is ok to abbreviate stream, right?) here. Then, in addition, I
would add a AVStream** and n_streams_in_set at the bottom of this
struct, or something. That would be all streams in this set. If you'd
prefer something else, let me know and I'll prepare patches.


More information about the ffmpeg-devel mailing list