[FFmpeg-devel] Google Summer of Code participation

Ronald S. Bultje rsbultje
Fri Apr 3 02:23:39 CEST 2009


On Thu, Apr 2, 2009 at 7:19 PM, Thilo Borgmann
<thilo.borgmann at googlemail.com> wrote:
> Michael Niedermayer schrieb:
>> decode_frame() should be changed not a new one added.
> Oh, I deducted this from the avcodec_decode_video2 creation... but ok will
> do.

The idea is to maintain API, that's why we have avcodec_decode_video()
and _video2(). The idea is that one calls the other and that that
implementation can handle both AVCodec.decode_video2() and
AVCodec.decode_video(), so that codecs only have to implement a single
one. This way, codecs stay simple and API is maintained while adding a
new feature.


More information about the ffmpeg-devel mailing list