[FFmpeg-devel] [PATCH] Only output necessary NAL units in H.264 extradata in SDP

Jason Garrett-Glaser darkshikari
Sat Apr 4 04:42:10 CEST 2009

On Fri, Apr 3, 2009 at 9:37 AM, Michael Niedermayer <michaelni at gmx.at> wrote:
> On Fri, Apr 03, 2009 at 07:25:06PM +0300, Martin Storsj? wrote:
>> Hi,
>> As noted by another user a month ago
>> (https://lists.mplayerhq.hu/pipermail/ffmpeg-devel/2009-March/064219.html),
>> the SDP data generated by ffmpeg for H.264 streams doesn't work with
>> QuickTime Player. I'm not sure if this is a change in recent versions of
>> QuickTime or a regression in ffmpeg, though.
>> QuickTime seems to dislike that the sprop-parameter-sets contains the
>> version and identification output from x264 (which is a quite large chunk
>> of data compared to the SPS and PPS parts). I also tested to shrink the
>> amount of info output by x264 into this nal unit, but even with a minimal
>> amount of data, it wouldn't play the content. Reordering the nal units (in
>> x264), putting this unit as the last one, didn't help either.
>> The attached patch solves this in two possible ways, please comment on
>> which one you find more reasonable.
> checking nal_type IMHO
> but first question, what does the RFC say? is what x264 stores ok in SDP or
> not?

Why not just stuff the SEI in the bitstream itself?

There is currently a rather nasty bug in the mp4 muxer where the x264
SEI simply gets lost--which makes it almost impossible to identify
streams for debugging.

Dark Shikari

More information about the ffmpeg-devel mailing list