[FFmpeg-devel] [FFmpeg-user] Remuxing for the PS3

Christian Iversen chrivers
Tue Apr 7 17:16:38 CEST 2009

John Lange wrote:
> On Mon, 2009-04-06 at 09:18 +0200, Patrik Kullman wrote:
>>> Also, for H.264, ffmpeg seems to set video type = 0x0000. I'm pretty 
>>> sure that's wrong too. In fact, it might be one of the major reasons the 
>>> PS3 wont recognize the video, come to think of it.
>>> (Or, it's just some wrong info ffmpeg displays on the screen only. I'm 
>>> not sure if 0x0000 actually goes into the file anywhere)
>> I was looking at this some time ago as well.
>> There was a couple of things I noticed.
>> First, the PS3 doesn't seem to play H264 Level 5.1, so it has to be
>> changed to 4.1.
> Correct, High 4.1 is the max the PS3 will play.
>> But more interestingly, tsMuxer seems to add the header like 10-15
>> times, apparently that is needed by some hardware decoders (including
>> the PS3?).
> In the version that I tested, this was an option though I didn't analyze
> the output to see if it was working as advertised.
> My understanding is that headers should appear only once in an mp4
> container, but if you're streaming h264 then obviously they have to be
> present throughout the stream.
> As I've said previously in this thread, step one would be to find a file
> (or settings for TSmuxer that generate a file) that actually plays on
> the PS3 so we can reverse engineer it but so far nobody has provided an
> example.

I'm sorry, I have been quite busy lately. I'll try to cook up some 
example of Good vs. Bad later.

Med venlig hilsen
Christian Iversen

More information about the ffmpeg-devel mailing list