[FFmpeg-devel] [PATCH] Split bitstream.h
Sat Apr 11 23:44:02 CEST 2009
On Sat, Apr 11, 2009 at 11:30:17PM +0200, Michael Niedermayer wrote:
> On Sat, Apr 11, 2009 at 10:26:28PM +0100, M?ns Rullg?rd wrote:
> > Ramiro Polla <ramiro.polla at gmail.com> writes:
> > > On Sat, Apr 11, 2009 at 3:27 PM, Stefano Sabatini
> > > <stefano.sabatini-lala at poste.it> wrote:
> > >> Hi, as suggested by Michael here it is a patch which splits
> > >> bitstream.h and creates a new bitstream_writer.h file.
> > >>
> > >> Maybe it would make sense to rename bitstream.h to bitstream_reader.h,
> > >> since it now only contains the reader stuff.
> > >
> > > Minor bikeshed: why not put_bits.h and get_bits.h?
> > Or bs_read.h and bs_write.h. bitstream_reader/writer strike me as a
> > bit long.
> bs is ambibous (bit vs. byte)
And there I was thinking it was short for "bullshit"...
More information about the ffmpeg-devel