[FFmpeg-devel] [PATCH] Core Audio Format demuxer (v3)

Diego Biurrun diego
Wed Aug 12 15:33:04 CEST 2009


On Wed, Aug 12, 2009 at 10:27:27PM +1000, Peter Ross wrote:
> On Mon, Aug 10, 2009 at 04:00:39PM +0200, Diego Biurrun wrote:
> > On Mon, Aug 10, 2009 at 11:19:27PM +1000, Peter Ross wrote:
> > > --- /dev/null
> > > +++ b/libavformat/cafdec.c
> > > @@ -0,0 +1,425 @@
> > > +static int read_pakt(AVFormatContext *s, int64_t size)
> > 
> > I think either _pkt or _packet would be better.
> 
> 'pakt' is the name the CAF spec authors have given to the 'Packet Table
> Chunk' type. For clarity i have renamed the read_xxxx() fuctions to
> read_xxxx_chunk()

Then clarify this in a comment or whatever, I could not guess it..

> --- a/libavformat/Makefile
> +++ b/libavformat/Makefile
> @@ -32,6 +32,7 @@ OBJS-$(CONFIG_AVS_DEMUXER)               += avs.o vocdec.o voc.o
>  OBJS-$(CONFIG_C93_DEMUXER)               += c93.o vocdec.o voc.o
> +OBJS-$(CONFIG_CAF_DEMUXER)               += cafdec.o caf.o riff.o mov.o
>  OBJS-$(CONFIG_CAVSVIDEO_DEMUXER)         += raw.o

Please doublecheck that it compiles standalone, i.e. with all other
demuxers, muxers, parsers, codecs.. disabled.

> --- /dev/null
> +++ b/libavformat/caf.c
> @@ -0,0 +1,58 @@
> +
> +/**
> + * Known codec tags for CAF.

I'd drop the capitalization and the period from this non-sentence.

> --- /dev/null
> +++ b/libavformat/cafdec.c
> @@ -0,0 +1,423 @@
> +    pkt_frames = caf->frames_per_packet;
> +    pkt_size = caf->bytes_per_packet;

align

Diego



More information about the ffmpeg-devel mailing list