[FFmpeg-devel] Build problem

Jason Garrett-Glaser darkshikari
Wed Feb 4 12:51:16 CET 2009

On Wed, Feb 4, 2009 at 2:45 AM, Robert Swain <robert.swain at gmail.com> wrote:
> 2009/2/4 M?ns Rullg?rd <mans at mansr.com>:
>> Reimar D?ffinger <Reimar.Doeffinger at stud.uni-karlsruhe.de> writes:
>>> On Wed, Feb 04, 2009 at 09:25:46AM +0000, M?ns Rullg?rd wrote:
>>>> Art Clarke <aclarke at xuggle.com> writes:
>>>> > I installed yasm on our Mac build boxes today, and noticed the
>>>> > following error doing x86_64 builds:
>>>> >
>>>> >>> ld: pointer in read-only segment not allowed in slidable image, used in dispatch_tab_sse from libavcodec/x86/fft_mmx.o
>>>> >
>>>> > I was wondering if people already knew why this occurs (a perusal of
>>>> > the archives suggested not).  If I don't have yasm installed or
>>>> > available on the path the build works fine.  Any thoughts or anyone
>>>> > else seeing this?
>>>> Yes, Apple is stupid as usual.  What that error message means is that
>>>> it doesn't allow relocations in read-only sections, which is utterly
>>>> silly.
>>> Well, in that specific case it might also be because the data gets
>>> placed in .text and not .rodata on OSX, supposedly because of alignment
>>> issues.
>> Wasn't there a hack for that?  Also, if that is the problem, using
>> latest yasm svn version should have a fix IIRC.
> Art: What version of yasm did you install? x264 requires a very recent
> version (0.7.x i think) and the asm code has been written by x264
> devs. Just install the latest version from the yasm site.

0.6.2, AFAIK.  Should work with 0.6.1 as well (x264 won't because of
lzcnt, but we don't use that in ffmpeg yet).

Dark Shikari

More information about the ffmpeg-devel mailing list