[FFmpeg-devel] xvmc_render.h ---> xvmc.h
Mon Feb 9 10:23:11 CET 2009
On 2/9/09, M?ns Rullg?rd <mans at mansr.com> wrote:
> Ivan Kalvachev <ikalvachev at gmail.com> writes:
>> On 2/8/09, Diego Biurrun <diego at biurrun.de> wrote:
>>> On Sun, Feb 08, 2009 at 01:15:54AM +0200, Ivan Kalvachev wrote:
>>>> On 2/7/09, Diego Biurrun <diego at biurrun.de> wrote:
>>>> > I suggest renaming xvmc_render.h ---> xvmc.h, similar to vdpau.h.
>>>> > There is no good reason for the _render suffix.
>>>> I'm against using generic names for external stuff.
>>>> If you want to rename something rename vdpau.
>>> vdpau was explicitly renamed from vdpau_render.h to vdpau.h.
>>> The same should be done for xvmc_render.h.
>>> Generic names are not a problem anymore, since we require that
>>> #includes should use libavcodec/ as prefix.
>> I still oppose the change as it brings more confusion
>> and have no advantages of any sort.
> What information does the _render suffix add? Can xvmc be used for
For one thing, it does not imply that this header does its own
implementation of the xvmc protocol like png.h does.
It only declares more stuff using the original implementation.
> anything other than (ultimately) rendering a video to screen? If the
> suffix adds nothing, it is redundant and should be removed.
In existing ffmpeg terminology render is never used to describe
showing video on the screen. Video is always drawn.
In this case render is the code that takes the exported data and
synthesizes the image. The term is used in same meaning
as 3D rendering.
This header is used to describe the structure(s) and labels
needed for communication with this application code.
Reimar, is this explanation good enough for you?
>> I still recommend the reversal of vdpau change that is done
>> without any significant reason.
> Not going to happen.
So you can see in the future?
Or you are so arrogant that you think you can never make mistake?
Or you just ignore any argument as insignificant and do whatever you want?
(huh, I'm already confusing you with Diego)
I have the feeling you proposed such confusing and conflicting
header name on purpose, to cause more problems in projects that
doesn't follow the exact including guidelines of ffmpeg.
Noble cause indeed.
xvmc_render.h remains as it is.
vdpau_render.h request still stands.
More information about the ffmpeg-devel