[FFmpeg-devel] [PATCH][8/8] Add VA API deps to configure

Gwenole Beauchesne gbeauchesne
Mon Feb 9 13:07:15 CET 2009


On Mon, 9 Feb 2009, Diego Biurrun wrote:

>> +pkg=libva-0.29
>> +check_pkg_config vaapi $pkg va.h vaInitialize
>> +if enabled vaapi; then
>> +    add_cflags `pkg-config --cflags $pkg`
>> +    add_extralibs `pkg-config --libs $pkg`
>> +fi
> Do you really need pkg-config?

In the upstream implementation? No, but in the internal tree at Intel and 
in our packages, yes. How do you want to fetch CFLAGS and the necessary 
libs otherwise? Note: VA API headers are now located in their own 
directory, so a -I/some/path is needed.

On the other hand, we just need to know the installed VA API version, and 
could infer the necessary bits -> -I${includedir}/va-VERSION and 

Or did you mean to merge the add_{cflags,extralibs} into the 
check_pkg_config on success?


More information about the ffmpeg-devel mailing list