[FFmpeg-devel] [PATCH][7/8] Add VA API accelerated H.264 decoding (take 4)

Diego Biurrun diego
Mon Feb 9 18:18:03 CET 2009

On Mon, Feb 09, 2009 at 06:08:45PM +0100, Gwenole Beauchesne wrote:
> On Mon, 9 Feb 2009, Diego Biurrun wrote:
> >> At the very least, you should have commented on the real implementation
> >> earlier/beforehand, not many weeks after commenting on pure *cosmetics*.
> >> That's a terrible waste of time, and totally suboptimal process. IOW,
> >> cosmetics are the last things to care about in a process, especially if
> >> those are things that could be done through an automated tool.
> >
> > I don't think anybody really realized the issues before.
> My current feeling is: s/realized/cared/, i.e. unwanted work and you are a 
> sadist. Really, all that happened as if, after many weeks of work, you 
> think yourself near because you only get complains about cosmetics and you 
> fixed those, but someone finally comes by and bothers telling you: "ahaha, 
> no, here are the new rules, try again man! You can put the current code to 
> the bin. rofl"...

That's not the way it works.  The more interest a patch generates, the more
comments it receives.  Most of these will be small issues until somebody
finds the time to review it in depth (usually Michael).  It's not uncommon
that superficial issues get addressed before this happens.  All those small
things do detract from the deeper issues.

You also have the bad luck of having modeled your work on xvmc (or on
vdpau, which is modeled on xvmc), one of the cruftiest parts of FFmpeg.
It's not your fault, it's bad luck, but it does not make the issues go
away.  We just start noticing them now that this hornet's nest is


More information about the ffmpeg-devel mailing list