[FFmpeg-devel] Rename [vdpau|xvmc]video.c --> [vdpau|xvmc].c
Tue Feb 10 18:31:27 CET 2009
On 2/10/09, M?ns Rullg?rd <mans at mansr.com> wrote:
> Ivan Kalvachev <ikalvachev at gmail.com> writes:
>> On 2/10/09, M?ns Rullg?rd <mans at mansr.com> wrote:
>>> Diego Biurrun <diego at biurrun.de> writes:
>>>> Let's fix some of the structure of the hardware acceleration APIs.
>>>> One thing are the file names, which are not very useful. I propose
>>>> vdpauvideo.c --> vdpau.c
>>>> xvmcvideo.c --> xvmc.c
>>> I second that. XVMC and VDPAU are both exclusively for video.
>> They are named towards mpegvideo*.c files that contain alternative
>> definitions of common routines for decoding video formats.
>> Renaming them in such plane way would indicate that xvmc implements
>> some kind of video/audio formats.
>> Better name could be mpegvideo_xvmc.c,
>> however vdpau contains more stuff than that.
> We have mpegvideo.c and mpegaudio.c. We do not have h264video.c or
> vp6video.c. The reason is that the MPEG specs include both video and
> audio formats, whereas H.264 and VP6 do not. If something *only*
> handles video, there is no need to mention this in the file name.
You just made that up.
mpeg12.c decodes mpeg video.
Obviously if I say sun rises from east, you'll find a way to prove me wrong.
"Now please stop trolling, and get back to coding, which you do very well."
Diego's change is not acceptable and is rejected.
More information about the ffmpeg-devel