[FFmpeg-devel] MPADecodeContext on stack

Michael Niedermayer michaelni
Thu Feb 12 01:54:25 CET 2009

.cOn Wed, Feb 11, 2009 at 09:53:36PM +0100, Andreas ?man wrote:
> Michael Niedermayer wrote:
> > On Thu, Feb 05, 2009 at 11:02:12AM +0100, Andreas ?man wrote:
> >> I don't have any lossless RGB JPEGs available to test with.
> > 
> > we support rgb ljpeg encoding
> Unfortunately it's not working that well, i made a few attempts
> into getting it running but without any luck. It's a bit
> frustrating since I've not been able to find any other
> lossless RGB JPEGs in the wild. I'd really like to verify
> that the decoder still works before I start to work with the encoder.
> So if anyone happens to have such a file, please say so :)
> And no, I've not found a sample on samples.mplayerhq...

i suggest you do a binary search in svn starting with when ljpeg rgb
was added. also keep in mind there was a nonsense check in mpegvideo
that blocked the encoder but its not the only issue it seemed there
is something with the bitstream decoding or encoding as well.

also if you choose to give up at least open a issue on roundup

and if you succeed please add a regression test for rgb32 ljpeg

Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Thouse who are best at talking, realize last or never when they are wrong.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20090212/a2e40e2e/attachment.pgp>

More information about the ffmpeg-devel mailing list