[FFmpeg-devel] Some footage for H264 on kdenlive.org

Ivan Schreter schreter
Sat Feb 21 12:22:33 CET 2009


Carl Eugen Hoyos wrote:
> Jean-Michel Pour? <jm <at> poure.com> writes:
>> On Fri, 2009-02-20 at 23:05 +0000, Carl Eugen Hoyos wrote:
>>> May I suggest that you try this patch:
>>> http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/2009-February/063242.html
>>> and report either in this thread or there which ones work/don't work.
>> Our samples are MPEG-TS and may
> [...]
> Does "may" mean you didn't try?
I personally have the Panasonic AVCHD camcorder.

The samples do decode correctly with my patches. I tested Panasonic, 
Sony and Canon AVCHD 1080i MPEG-TS movies. They all worked.

HOWEVER: For use with kdenlive (nonlinear video editor), seeking has to 
work as well. I suppose, Jean-Michel meant that timestamping issue is 
just half of the solution. The other half is correct MPEG-TS seeking (it 
ignores key frames currently). I posted some patches regarding that as 
well to the ML, but the response rate to my patches and questions on the 
ML was quite low...

Additionally, MLT framework (used as base for kdenlive) doesn't support 
field-based movies yet, so only 1080p AVCHD movies work in kdenlive 
(with my seeking patches), but no 1080i movies. My previous solution 
with frame combining in FFmpeg was rejected (which would allow MLT to 
work correctly). I'm also trying to prepare something on MLT front to 
get field-based movies supported fully.



More information about the ffmpeg-devel mailing list