[FFmpeg-devel] AAC/RTP crash

Robert Swain robert.swain
Thu Feb 26 01:12:04 CET 2009

2009/2/25 Ronald S. Bultje <rsbultje at gmail.com>:
> Hi Robert,
> On Thu, Jan 15, 2009 at 9:40 AM, Robert Swain <robert.swain at gmail.com> wrote:
>> 2009/1/15 Ronald S. Bultje <rsbultje at gmail.com>:
>>> With the built-in decoder instead of faad, RTP streams containing AAC
>>> data can crash ffplay. Example below:
>>> $ ./ffplay rtsp://video.medinfo.ufl.edu/opeta/MS_all.mov
>>> Program received signal EXC_BAD_ACCESS, Could not access memory.
>>> Reason: KERN_PROTECTION_FAILURE at address: 0x000000e5
>>> [Switching to process 28864 thread 0x7eab]
>>> 0x001467e3 in aac_decode_frame (avccontext=???, data=???,
>>> data_size=???, buf=???, buf_size=???) at libavcodec/aac.c:1493
>>> 1493 ? ? ? ? ? ? ? ? ? ?if(che->ch[0].tns.present)
>>> I'm affraid I don't get a backtrace or any useful debugging data
>>> (which is a completely different issue that I should at some point ask
>>> questions about :-) ), but maybe one of the AAC decoder devs can
>>> reproduce this and look at it? This used to work fine with the faad
>>> decoder, and the RTP/AAC payload parser didn't change since then.
>> Compiled with --enable-debug=3 and run the ffplay_g binary in gdb I
>> assume...? I'll have a look later or tomorrow.
> Did you ever have a chance to look at this?

Sorry, I had misplaced this mail. It's flagged now so it won't get
lost. Unfortunately my internet connection is bad at the moment
(30kB/s downstream, DNS often not resolving) but I will check it soon.

Have you tested it again? Can you give the gdb output from ffplay_g or ffmpeg_g?


More information about the ffmpeg-devel mailing list