[FFmpeg-devel] [PATCH]VDPAU patch for VC1 decoding, round 1
Mon Jan 12 01:12:40 CET 2009
M?ns Rullg?rd wrote:
> Aurelien Jacobs <aurel at gnuage.org> writes:
> > Aurelien Jacobs wrote:
> >> Diego Biurrun wrote:
> >> > On Wed, Jan 07, 2009 at 10:50:39PM +0100, Carl Eugen Hoyos wrote:
> >> > >
> >> > > --- libavcodec/vc1.c (revision 16481)
> >> > > +++ libavcodec/vc1.c (working copy)
> >> > > @@ -4317,3 +4338,35 @@
> >> > > +
> >> > > +#if ENABLE_WMV3_VDPAU_DECODER
> >> >
> >> > Using ENABLE_ here is still wrong...
> >> I disagree. Using #if ENABLE_ is better than #ifdef CONFIG_.
> >> It is more readable, shorter, and more consistent especially
> >> in cases such as:
> >> #if ENABLE_A
> >> #elif ENABLE_B
> >> #endif
> >> or
> >> #if ENABLE_A || ENABLE_B
> >> Moreover, #if gives a chance to the compiler to complain if
> >> there is a typo in the symbol name. With #ifdef, such a
> >> typo could stay unnoticed for a long time.
> >> Now I expect some answer about consistency because the code
> >> supposedly contains more occurence of #ifdef CONFIG_ than
> >> #if ENABLE_.
> >> The attached patch solves this by replacing all usage of
> >> CONFIG_ by ENABLE_.
> >> With this applied, we could also drop all CONFIG_ from
> >> config.h.
> > It seems there is no objection to this patch anymore ?
> I already said I objected.
The only objection you raised is that you want to keep the
distinction between CONFIG_ and HAVE_. As I've already
explained, I have not proposed to change the HAVE_ at all,
and thus, I've not proposed to remove this distinction.
Now, do you have any other concern ?
Is it with the naming (CONFIG vs. ENABLE) ?
Or with the semantic (0/1 vs. un/defined) ?
More information about the ffmpeg-devel