[FFmpeg-devel] Broken compile with latest libavutil/common.h

Måns Rullgård mans
Wed Jan 14 23:23:44 CET 2009

"Chris Silva" <2manybills at gmail.com> writes:

> /usr/local/include/libavutil/common.h:326:14: error: operator '||' has no left operand
> ---- line 326
> +#if ARCH_X86 || ARCH_PPC || ARCH_BFIN
> Is this a xine-lib problem or a ffmpeg problem?

Looks like it's our fault.  That certainly won't work in an installed
header.  Thanks for telling us.

M?ns Rullg?rd
mans at mansr.com

More information about the ffmpeg-devel mailing list