[FFmpeg-devel] RTP mark bit not passed to parse_packet
Thu Jan 15 14:43:30 CET 2009
Ronald S. Bultje wrote:
>> Yes, I'd love to see this committed :)
>> FWIW, instead of
>> flags |= (buf & 0x80) << 1
>> I'd prefer the more readable variant:
>> if (buf & 0x80) flags |= RTP_FLAG_M_BIT;
> Sure, no problem. Luca, agree?
I do not know... I think this is Luca B.'s reign.
> Michael, is a "format-specific" or
> "private" flag mask of >= 0x100 or 0x10000 OK in avformat.h?
BTW, what has avformat.h to do with this flag? Isn't the "flags"
variable passed to parse_packet() internal to the RTP
(and, BTW, what is it used for? In rtp_parse_packet() we have
"flags = 0" and the value is never changed... And it does not
appear to be documented anywhere...)
More information about the ffmpeg-devel