[FFmpeg-devel] [PATCH] libx264 psyrd update V3

Jason Garrett-Glaser darkshikari
Wed Jan 21 22:41:40 CET 2009

On Wed, Jan 21, 2009 at 4:34 PM, Marcus Blomenkamp <mblomenk at gmx.de> wrote:
>> If they're enabled by default, why do you have to specify it *again*
>> in all the preset files?
>> Dark Shikari
> ffmpeg internal defaults differ from libx264 defaults, for example subq/subme is set to 8 as default, not inside the libx264-ffmpeg glue code but for all codecs.

But psy-rd is an x264-specific option, so why not give it the correct
value to begin with?  This repeating of settings in all presets seems
like an extremely ugly workaround for a non-problem!

> In order not to change application bahaviour for foreign codecs (now and in the future) i have decided to move libx264 specific policies into preset files. Why do you think this is a bad idea?

Presets are not a proper substitute for the lack of proper per-codec
defaults in ffmpeg.

Dark Shikari

More information about the ffmpeg-devel mailing list