[FFmpeg-devel] [patch]rename read_seek2 to seek_file
Wed Jul 22 00:46:09 CEST 2009
On 07/21/2009 03:32 PM, Diego Biurrun wrote:
> On Wed, Jul 22, 2009 at 12:31:50AM +0200, Aurelien Jacobs wrote:
>> On Wed, Jul 22, 2009 at 12:23:50AM +0200, Michael Niedermayer wrote:
>>> On Tue, Jul 21, 2009 at 10:05:10PM +0800, zhentan feng wrote:
>>>> the patch rename read_seek2 to seek_file.
>>> if people prefer "seek_file" over "read_seek2" then ok
>>> otherwise not
>> I don't mind about the name itself, but changing it would
>> break API and so would need a major version bump.
> We can rename with the next major version bump as usual..
Well, IMHO the rename is fine:
* @NOTE This is part of the new seek API which is still under
* Thus do not use this yet. It may change at any time, do not expect
* ABI compatibility yet!
Baptiste COUDURIER GnuPG Key Id: 0x5C1ABAAA
Key fingerprint 8D77134D20CC9220201FC5DB0AC9325C5C1ABAAA
FFmpeg maintainer http://www.ffmpeg.org
More information about the ffmpeg-devel