[FFmpeg-devel] [BUG] Unable to compile with --enable-runtime-cpudetect on Mac OS X

Patrice Bensoussan patrice.bensoussan
Thu Jun 25 00:12:05 CEST 2009


I'm trying to compile ffmpeg for ppc so that it can run on both G3 and  
G4 (using altivec with G4). It seems that --enable-runtime-cpudetect  
option has been introduced recently in configure, so I assume it would  
be the option to use to achieve what I want to do... but doesn't seem  
to work... Am I missing something or is this a known issue/limitation?

/Users/patriceb/tmp/WMA/ffmpeg/libswscale/swscale.c: In function  
/Users/patriceb/tmp/WMA/ffmpeg/libswscale/swscale.c:2001: warning:  
implicit declaration of function ?sws_init_swScale_C?
/Users/patriceb/tmp/WMA/ffmpeg/libswscale/swscale.c:2002: error:  
?swScale_C? undeclared (first use in this function)
/Users/patriceb/tmp/WMA/ffmpeg/libswscale/swscale.c:2002: error: (Each  
undeclared identifier is reported only once
/Users/patriceb/tmp/WMA/ffmpeg/libswscale/swscale.c:2002: error: for  
each function it appears in.)

Here is my configure line (I am compiling on an Intel Mac for PPC, not  
sure if this matters in this case...):
(notice that it compiles fine for Intel, so issue seems to be ppc  

configure --enable-runtime-cpudetect --enable-nonfree --disable-bzlib  
--enable-pthreads --disable-network --enable-small --enable-libmp3lame  
--enable-libfaac --arch=ppc --disable-decoder=atrac3 --extra-ldflags="- 
isysroot /Xcode2.5/SDKs/MacOSX10.3.9.sdk -arch ppc --extra-cflags="- 
isysroot /Xcode2.5/SDKs/MacOSX10.3.9.sdk -arch ppc --enable-gpl -- 
enable-libx264 --enable-libfaad

Any help would be appreciated on this... (it used to work fine before  
this option was introduced I believe) Thanks! Also, are we now  
supposed to use --disable-altivec so that it can actually run on both  
G3 and G4?


More information about the ffmpeg-devel mailing list