[FFmpeg-devel] [PATCH][8/8] Add VA API deps to configure (take 2)

Måns Rullgård mans
Tue Mar 3 14:50:44 CET 2009

Gwenole Beauchesne <gbeauchesne at splitted-desktop.com> writes:

> On Tue, 3 Mar 2009, Diego Biurrun wrote:
>> On Tue, Mar 03, 2009 at 11:26:07AM +0100, Gwenole Beauchesne wrote:
>>> OK, I dropped pkg-config and updated libva. Also sanitized VA API headers
>>> so that they build with plain -std=c99. Too bad ISO C does not support
>>> anonymous unions yet.
>> I think you should be able to get rid of the vaapi option altogether,
>> like I did for xvmc.  Some suggestions below:
> I think keeping the option is desirable as some people would want to 
> disable feature X or Y without uninstalling the feature-devel package.
>>> @@ -2017,6 +2031,7 @@
>>>                          die "ERROR: libx264 version must be >= 0.65."; }
>>>  enabled libxvid    && require  libxvid xvid.h xvid_global -lxvidcore
>>>  enabled mlib       && require  mediaLib mlib_types.h mlib_VectorSub_S16_U8_Mod -lmlib
>>> +enabled vaapi      && require  libva va/va.h vaInitialize -lva
>> Is this really needed?
> to define va_va_h and add -lva linker flag in a single line?

Use check_lib for that.  require aborts the script if the check fails.

M?ns Rullg?rd
mans at mansr.com

More information about the ffmpeg-devel mailing list